Dashboard Login Unavailable
Resolved
Oct 21 at 02:31am UTC
The issue with our upsteam provider has been resolved and dashboard login capabilities have been restored. We will continue to monitor to ensure there is no additional impact.
Affected services
Created
Oct 20 at 07:27pm UTC
Starting October 20, 2025 at 7:27 PM UTC, we are experiencing service disruptions affecting customer login to the Abra dashboard. This is due to an ongoing AWS service outage impacting authentication services in our primary region.
Current Impact:
- Customers are currently unable to log in to the Abra dashboard
- Existing active sessions may continue to function normally
- All other Abra services, including meeting recording capabilities, remain operational.
The Abra team is actively monitoring this issue with AWS and we will provide updates as new information becomes available.
Affected services