Partial Service Degradation
Resolved
Nov 18 at 06:30pm UTC
The Cloudflare outage has been resolved, and Abra's dashboard is back to normal performance. We appreciate your patience as we worked through this third-party issue.
Affected services
Updated
Nov 18 at 04:51pm UTC
We continue to monitor Cloudflare's outage. Dashboard performance remains degraded, but all data is secure, and meeting bots are functioning normally.
Affected services
Created
Nov 18 at 12:51pm UTC
Abra is currently affected by the ongoing Cloudflare outage. While our dashboard is experiencing significantly degraded performance, all existing data remains safe and secure. Meeting bots continue to operate normally.
We're monitoring the situation closely and will provide updates as Cloudflare resolves the issue.
Affected services